Lichen

docs/wiki/Prerequisites

932:c07b0dd14f85
11 months ago Paul Boddie Moved integer instantiation support to library functions.
     1 = Prerequisites =     2      3 The software currently requires Python to operate. All recent development has     4 been done using Python 2.7 which should be available for most operating system     5 distributions. In future, Lichen will hopefully be compiled using its own     6 toolchain and not require Python. See the Debian `python-minimal` or `python`     7 packages or their equivalents.     8      9 To produce executable programs, a C compiler and GNU make are required. The GNU    10 C compiler, GCC, has been used for development and testing, and it should be    11 available in various forms for most operating system distributions. Indeed,    12 cross-compiling form of GCC has been used to test the toolchain output. See the    13 Debian `gcc` and `make` packages or their equivalents.    14     15 As Free Software, priority has been given to supporting Lichen on Free Software    16 platforms, with Debian GNU/Linux being the development platform. Proprietary    17 platforms are neither supported nor recommended.